通达信九转MACD指标公式

通达信公式 2019-11-16 16:55:54

DIF:EMA(C,12)-EMA(C,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.5,0),COLORLIRED;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,0.5,0),COLORLIGREEN;
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,MAX(DIF,MACD)*1.1,VAR2STR(AY,0)),COLORGREEN;
DRAWTEXT(NT=9,MAX(DIF,MACD)*1.1,'9'),COLORGREEN;
B1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,MIN(DIF,MACD)*1.2,VAR2STR(AY1,0)),COLORLIMAGENTA;
DRAWTEXT(NT0=9,MIN(DIF,MACD)*1.2,'9'),COLORMAGENTA;

 

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文