机构散户资金分时主图指标公式

秀股网 通达信公式 2019-09-21 18:04:18
DRAWGBK(1,RGB(0,0,0),RGB(1,1,1),1,0,0);
VR1:=1270915;VR2:=1270920;
VR3:=IF(DATE>VR1,IF(CLOSE<80,1,0),0);
VR4:=IF(DATE>VR2,1,VR3);
P2:=IF(VR3=1,0,240);
TC1:=IF(H=HHV(H,P2),C,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=H))+1;
UPPER:=CONST(IF(TC2=1,C,REF(C,TC2-1)));
BC1:=IF(L=LLV(L,P2),C,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LOWER:=CONST(IF(BC2=1,C,REF(C,BC2-1)));
NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2));{用时}
LR1:=FORCAST(C,NOD+1);
NP:=IF(CURRBARSCOUNT<=MAX(BC2,TC2),CONST(IF(MIN(TC2,BC2)=1,LR1,REF(LR1,MIN(TC2,BC2)-1))),DRAWNULL),POINTDOT,COLORLIGRAY;{近点}
LR2:=SLOPE(C,NOD+1);
LR3:=CONST(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)-1)));
FP:=NP-LR3*(NOD),POINTDOT,COLORGRAY;{远点}
EQU:=(NP+FP)/2,POINTDOT,COLOR0000FF;
AD:=ABS(NP-FP);{高差};
DBL:=BARSLAST(BC1!=DRAWNULL)+1;
DBH:=BARSLAST(TC1!=DRAWNULL)+1;
BSP:=IF(BC2>TC2,DBL,DBH)-1;
LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP);
AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND H>LRL,H,LRL);
AT2:=HHV(AT1-LRL,MAX(BC2,TC2));
AT3:=CONST(BARSLAST(AT1-LRL=AT2));
AT4:=CONST(IF(AT3=0,H,REF(H,AT3)));
AT5:=CONST(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)));
ATL:=LRL+AT5;
UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L<LRL,L,LRL);
UT2:=HHV(LRL-UT1,MAX(BC2,TC2));
UT3:=CONST(BARSLAST(LRL-UT1=UT2));
UT4:=CONST(IF(UT3=0,H,REF(H,UT3)));
UT5:=CONST(IF(UT3=0,LRL-UT1,REF(LRL-UT1,UT3)));
UTL:=LRL-UT5;
RH:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,ATL,CONST(REF(ATL,MIN(BC2,TC2)-11)));{限制高}
RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,CONST(REF(UTL,MIN(BC2,TC2)-11)));{限制低}
中轨2:=IF(NP>FP,IF(LRL<=RH,LRL,DRAWNULL),IF(LRL>=RL,LRL,DRAWNULL)),COLORBLUE,,DOTLINE;
上轨2:=IF(NP>FP,IF(ATL<=RH,ATL,DRAWNULL),IF(ATL>=RL,ATL,DRAWNULL)),COLORMAGENTA,,DOTLINE;
下轨2:=IF(NP>FP,IF(UTL<=RH,UTL,DRAWNULL),IF(UTL>=RL,UTL,DRAWNULL)),COLOR00EE00,,DOTLINE;
T30:=IF(BARSSINCE(C>0)>=30,1,0);
{画线}
{IF(T30 AND 上轨2>REF(上轨2,2),上轨2,DRAWNULL),COLOR660066;
IF(T30 AND 中轨2>REF(中轨2,2),中轨2,DRAWNULL),COLOR660066;
IF(T30 AND 下轨2>REF(下轨2,2),下轨2,DRAWNULL),COLOR660066;
IF(T30 AND 上轨2<=REF(上轨2,2),上轨2,DRAWNULL),COLOR999900;
IF(T30 AND 中轨2<=REF(中轨2,2),中轨2,DRAWNULL),COLOR999900;
IF(T30 AND 下轨2<=REF(下轨2,2),下轨2,DRAWNULL),COLOR999900;}
X_1:=SUM(VOL*CLOSE,0)/SUM(VOL,0);
X_2:=EMA(X_1,50)/0.97;
X_3:=(X_1+X_2)/2;
DRAWBAND(X_2,RGB(100,30,0),X_3,0);{上轨填充色}
DRAWBAND(X_3,RGB(0,100,50),X_1,0);
上轨:X_2,COLORGREEN,LINETHICK2;
上轨变色:IF(X_2>REF(X_2,1),X_2,DRAWNULL),COLORRED,LINETHICK2;
中轨:X_3,COLORYELLOW;
下轨:X_1,COLORBLUE;
现价:CLOSE,COLORWHITE,LINETHICK2;
X_4:=CONST(REF(CLOSE,480));
X_5:=CONST(HHV(HIGH,480));
X_6:=CONST(LLV(LOW,480));
X_7:=EMA(CLOSE,30);
X_8:=EMA(CLOSE,900);
X_9:=MAX(X_4,X_5);
X_10:=MIN(X_4,X_6);
X_11:=X_9-X_10;
X_12:=X_10+X_11*7/8;
X_13:=X_10+X_11*0.5/8;
漂移点1:=DRAWICON(LONGCROSS(X_13,CLOSE,2),CLOSE*0.995,7);
漂移点2:=DRAWICON(LONGCROSS(CLOSE,X_12,2),CLOSE*1.005,8);
X_14:=BARSCOUNT(CLOSE);
X_15:=CROSS(CLOSE,REF(HHV(HIGH,X_14),1)) AND CLOSE/X_1<1.09 AND X_14>=1 AND X_14<240;
DRAWICON(FILTER(X_15,1),X_1,32);{分时轨道小图标}
FSX_1:=CONST(REF(CLOSE,480));
FSX_2:=CONST(HHV(HIGH,480));
FSX_3:=CONST(LLV(LOW,480));
FSX_4:=MAX(FSX_1,FSX_2);
FSX_5:=MIN(FSX_1,FSX_3);
FSX_6:=FSX_4-FSX_5;
FSX_9:=SUM(CLOSE*VOL,BARSSINCE(VOL>0)+1)/SUM(VOL,BARSSINCE(VOL>0)+1)+(BARSSINCE(VOL>0)+1)*0;
FSX_12:EMA(EXPMA(CLOSE,20),13)COLORMAGENTA;
均价:=FSX_9,COLORYELLOW,LINETHICK2;
阻力FS:=FSX_5+FSX_6*7/8;
支撑FS:=FSX_5+FSX_6*1/8;
{FS顶:=STICKLINE(C>阻力FS,C,阻力FS,1,0),COLORGREEN;}
FS底:=STICKLINE(C<支撑FS,C,支撑FS*1.005,1,0),COLORRED;
攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN);
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN);
攻击流量:=攻击量A+攻击量B;
攻击比:=攻击流量/SUM(V,FROMOPEN)*100;
资金攻击度:=IF(攻击比>=0,(攻击比+50),100-ABS((攻击比-50)));
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN);
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN);
资金出入:=资金流入+资金流出;
资金比:=资金出入/SUM(V,FROMOPEN)*100;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));
DRAWTEXT_FIX(1,0.2,1,1,STRCAT(STRCAT('【资金流量比】',CON2STR(资金流量比,2)),'%买'));
DRAWTEXT_FIX(1,0.2,0.93,1, STRCAT(STRCAT('【资金攻击度】',CON2STR(资金攻击度,2)),'%买'));
XGBB:=HHV(H,480);
去除5:=STICKLINE(FILTER(CROSS(C,REF(XGBB,1)),10) AND C>REF(XGBB,1),C*0.99,C,8,0);
去除6:=DRAWTEXT(FILTER(CROSS(C,REF(XGBB,1)),10) AND C>REF(XGBB,1),C*0.99,'突破');
RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
MA1:=REF(C,JY);
MA2:=REF(MA1,JY);
MA3:=REF(MA2,JY);
MA4:=REF(MA3,JY);
MA5:=REF(MA4,JY);
MA6:=REF(MA5,JY);
MA7:=REF(MA6,JY);
MA8:=REF(MA7,JY);
MA9:=REF(MA8,JY);
CK:=REFDATE((C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,DATE);
去除8:=DRAWTEXT(ISLASTBAR,CK,' 参考线');
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);
DEA:=EMA(DIF,9);
MACD1:=10*(DIF-DEA);
MACD2:=EMA(MACD1,2);
去除1:=STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0);
去除2:=STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0);
去除3:=STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0);
去除4:=STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0);
XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
底:=1;1.02,NODRAW;高:=1.03;
DRAWTEXT(CROSS(主力,1.02),C*0.999,'-突');
DRAWRECTREL(0,960,300,1000,RGB(0,250,50));{绿色}
DRAWRECTREL(0,965,0+CONST(资金攻击度*300/100),995,RGB(200,50,0));
DRAWRECTREL(147,960,153,1000,RGB(0,75,200));{0轴小条}
DRAWRECTREL(159,960,165,1000,RGB(20,50,20));{起爆位置小条}
DRAWRECTREL(0,915,300,955,RGB(0,250,50));{绿色}
DRAWRECTREL(0,920,0+CONST(资金流量比*300/100),950,RGB(178,34,34));{攻击条};
DRAWRECTREL(147,915,153,955,RGB(0,75,200));{0轴}
DRAWRECTREL(165,915,171,955,RGB(20,50,20));{起爆位置小条}
{机构买卖盘}
A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
机构买盘:=(A2);
机构卖盘:=(A3);
散户买盘:=(A4);
散户卖盘:=(A5);
DRAWTEXT_FIX(1,0.62,0.93,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),'万'))COLORRED;
DRAWTEXT_FIX(1,0.62,1,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),'万'))COLORGREEN;
DRAWTEXT_FIX(1,0.75,0.93,0,STRCAT(STRCAT('【散户买盘】',CON2STR(散户买盘,2)),'万'))COLORRED;
DRAWTEXT_FIX(1,0.75,1,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),'万'))COLORGREEN;
DRAWTEXT_FIX(1,0.35,0.93,0, STRCAT(STRCAT('【资金流量比】',CON2STR(资金流量比,2)),'%买')),COLORMAGENTA;
DRAWTEXT_FIX(1,0.35,1,0,STRCAT(STRCAT('【资金攻击度】',CON2STR(资金攻击度,2)),'%买')),COLORYELLOW;
{沪深总上涨下跌家数}
III1:=STRCAT('沪深总上涨家数:',CON2STR(DYNAINFO(60),0));
III2:=STRCAT('沪深总下跌家数:',CON2STR(DYNAINFO(61),0));
DRAWTEXT_FIX(ISLASTBAR,0.5,0.93,0,III1),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.5,1,0,III2),COLORLIGREEN;
DRAWTEXT_FIX(1,0.9,0.93,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.9,1,0,HYBLOCK),COLORRED;
DRAWTEXT_FIX(1,0.9,1,0,EXTERNSTR(0,1)),COLORWHITE;
{字码}
量价:=(VOL/CLOSE)/3;
B2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
B3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
B6:=B2+B3;DD1:=1;比:=B2/B3;
机构买入:=A2;
机构卖出:=A3;
机构总买入:=A2-A3;
散户买入:=A4;
散户卖出:=A5;
散户总买入:=A4-A5;
机构总色柱:=A2+A3;
机构买入比:=A2/机构总色柱*100;
AAA1:=STRCAT(STRCAT('机构买入',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖出',CON2STR((100*A3)/A6,0)),'%');
AAA0:=STRCAT(STRCAT('机构总买入',CON2STR((100*(A2-A3))/A6,0)),'%');
AAA3:=STRCAT(STRCAT('散户买入',CON2STR((100*A4)/A6,0)),'%');
AAA4:=STRCAT(STRCAT('散户卖出',CON2STR((100*A5)/A6,0)),'%');
AAA5:=STRCAT(STRCAT('散户总买入',CON2STR((100*(A4-A5))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0.18,0.93,0,AAA1),COLORBLACK;
DRAWTEXT_FIX(DD1=1,0.18,1,0,AAA2),COLORBLACK;
DRAWTEXT_FIX(DD1=1,0.24,0.93,0,AAA3),COLORRED;
DRAWTEXT_FIX(DD1=1,0.24,1,0,AAA4),COLORRED;
DRAWRECTREL(0,870,300,910,RGB(0,250,50));{绿色}
DRAWRECTREL(0,875,CONST(机构买入比*300/100),905,RGB(200,50,0));
{DRAWRECTREL(0,880,CONST(机构买入比*300/100),900,RGB(255,210,0));}
DRAWRECTREL(147,870,153,910,RGB(0,75,200));{0轴小条}
{新加1-临时撑压线}
破顶:=COST(99),COLORCYAN,CROSSDOT;{2条临时撑压线}
铁底:=COST(1),COLORCYAN,CROSSDOT;
平均价:(SUM((VOL * CLOSE),FROMOPEN) / SUM(VOL,FROMOPEN)),COLORYELLOW;
{新加2-撑压线}
XA_1:=MAX(DYNAINFO(3),DYNAINFO(5));
XA_2:=MIN(DYNAINFO(3),DYNAINFO(6));
XA_3:=XA_1-XA_2;
阻力:XA_2+XA_3*7/8,COLORYELLOW,LINETHICK2;{撑压线}
支撑:XA_2+XA_3*0.5/8,COLORRED,LINETHICK2;
XA_4:=CLOSE;
DRAWICON(LONGCROSS(支撑,XA_4,2),支撑*0.998,1);{1号2号小图标}
DRAWICON(LONGCROSS(XA_4,阻力,2),XA_4,2);
{新加3-强弱分界线}
强弱分界:EMA(CLOSE,720),CROSSDOT,LINETHICK2,COLORRED;{强弱分界线}
HJ_1:=MAX(DYNAINFO(3),DYNAINFO(5));
HJ_2:=MIN(DYNAINFO(3),DYNAINFO(6));
HJ_3:=HJ_1-HJ_2;
压力位:=HJ_2+HJ_3*7/8,COLORMAGENTA;
支撑位:=HJ_2+HJ_3*0.5/8,COLORMAGENTA;
HJ_4:=CLOSE;
HJ_5:=(CLOSE-REF(CLOSE,5))/REF(CLOSE,5);
BAB1:=STICKLINE(HJ_5>0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
BAB2:=STICKLINE(HJ_5<0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
HJ_6:=CLOSE/DYNAINFO(3);
HJ_7:=FILTER(HJ_5>0.015 AND HJ_5>REF(HJ_5,1)*2 AND VOL>REF(VOL,1)*2 AND CLOSE>REF(CLOSE,1) OR HJ_5>0.025,240);
DRAWICON(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,23);{东风小图标}
DRAWICON(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,1);
DRAWTEXT(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,' 东风来了')COLORYELLOW;
S木子0:=REF(CLOSE,1);
S木子1:=REF(MAX(HIGH,S木子0),1);
S木子2:=REF(MIN(LOW,S木子0),1);
MACS:=(MA((((S木子1 - S木子2) / REF(CLOSE,2)) * 100),5) / 4);
EMACS:=(EMA((((S木子1 - S木子2) / REF(CLOSE,2)) * 100),5) / 4);
NOTEXT前收盘价:=REF(CLOSE,1)NODRAW;
NOTEXT上市周期:=BARSSINCE(CLOSE)NODRAW;
NOTEXTMA5:=MA(CLOSE,5);
NOTEXTMA10:=MA(CLOSE,10);
NOTEXTMA20:=MA(CLOSE,20);
NOTEXTMA60:=MA(CLOSE,60);
NOTEXTRMA5:=REF(MA(CLOSE,5),1);
NOTEXTRMA10:=REF(MA(CLOSE,10),1);
NOTEXTRMA20:=REF(MA(CLOSE,20),1);
NOTEXTRMA60:=REF(MA(CLOSE,60),1);
NOTEXT大盘价位:=INDEXC;
NOTEXT昨日大盘:=REF(INDEXC,1);
TT2:=1000;
木子0:=(BARSLAST(((HOUR = 9) AND (MINUTE = 31))) + 1);
木子1:=((AMOUNT / VOL) / 100);
木子2:=(SUM((CLOSE * VOL),0) / SUM(VOL,0));
木子3:=(((SETCODE = 0) OR (SETCODE = 1)) AND (CLOSE < 500));
HHH:=IF(((SETCODE < 2) AND (CONST(BARSSINCE(CLOSE)) < 241)),CONST(IF((TIME < TT2),HHV(CLOSE,0),SUM((IF((TIME = TT2),1,0) * HHV(CLOSE,0)),0))),DRAWNULL),DOTLINE,COLORFF0000;
LLL:=IF(((SETCODE < 2) AND (CONST(BARSSINCE(CLOSE)) < 241)),CONST(IF((TIME < TT2),HHV(CLOSE,0),SUM((IF((TIME = TT2),1,0) * LLV(CLOSE,0)),0))),DRAWNULL),DOTLINE,COLORFF0000;
木子6:=IF(木子3,木子1,木子2);
价位:=CLOSE,LINETHICK4,COLORWHITE;
木子8:=MACS#DAY;{"NCFSYY00.MACS#DAY";}
木子9:=(木子8 * 1.3);
木子10:=((CLOSE > REF(CLOSE,1)) AND ((CLOSE / 木子6) > (1 + (木子8 / 100))));
木子11:=((CLOSE < REF(CLOSE,1)) AND ((CLOSE / 木子6) < (1 - (木子8 / 100))));
木子12:=((REF(SUM(木子10,0),1) = 0) AND (SUM(木子10,0) = 1));
木子13:=((REF(SUM(木子11,0),1) = 0) AND (SUM(木子11,0) = 1));
木子14:=(SUM(木子12,0) * CROSS(COUNT((CLOSE < REF(CLOSE,1)),BARSLAST(木子12)),0.5));
木子15:=(SUM(木子13,0) * CROSS(COUNT((CLOSE > REF(CLOSE,1)),BARSLAST(木子13)),0.5));
CS1:=CONST(SUM(IF(木子14,REF(CLOSE,1),DRAWNULL),0)),LINETHICK2,COLORGREEN;
CB1:=CONST(SUM(IF(木子15,REF(CLOSE,1),DRAWNULL),0)),LINETHICK2,COLORMAGENTA;
木子18:=CROSS(SUM((木子10 AND (CLOSE > (CS1 * (1 + (木子9 / 100))))),0),0.5);
木子19:=CROSS(SUM((木子11 AND (CLOSE < (CB1 * (1 - (木子9 / 100))))),0),0.5);
木子20:=(SUM(木子18,0) * CROSS(COUNT((CLOSE < REF(CLOSE,1)),BARSLAST(木子18)),0.5));
木子21:=(SUM(木子19,0) * CROSS(COUNT((CLOSE > REF(CLOSE,1)),BARSLAST(木子19)),0.5));
CS2:=CONST(SUM(IF(木子20,REF(CLOSE,1),DRAWNULL),0)),COLORGREEN;
CB2:=CONST(SUM(IF(木子21,REF(CLOSE,1),DRAWNULL),0)),COLORMAGENTA;
LF1:=木子12 OR 木子18 ;
LF2:=木子13 OR 木子19 ;
LF3:=木子15 OR 木子21 ;
LF4:=木子14 OR 木子20 ;
DRAWICON(LF1,(CLOSE*1.005),8);{S点}
DRAWICON(LF4,CLOSE,39);
DRAWICON(LF2,(CLOSE*0.995),7);{B点}
DRAWICON(LF3,CLOSE,38);
{底部红条顶部绿条}
F顶:=STICKLINE(C>压力位,C,压力位,1,0),COLORGREEN;
F底:=STICKLINE(C<支撑位,C,支撑位*1.008,1,0),COLORRED;
{超级分时}
CJFSVAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(CJFSVAR1-REF(CJFSVAR1,1))/REF(CJFSVAR1,1)*1000;
CJFSJJ:=AMOUNT/VOL/100;
CJFSP:=55;
CJFSS:=8;
CJFSM1:=3;
财:=(EMA(CLOSE,CJFSS)-EMA(CLOSE,CJFSP))*10;
神:=EMA(财,CJFSM1);
BTJ1:=(CLOSE-CJFSJJ)/CJFSJJ<(-0.005);
BTJ11:=(CLOSE-CJFSJJ)/CJFSJJ<(-0.03);
BTJ12:=LAST(CJFSJJ>=REF(CJFSJJ,1),5,1) AND (CLOSE-CJFSJJ)/CJFSJJ<0.005;
STJ1:=(CLOSE-CJFSJJ)/CJFSJJ>0.005;
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<(-0.2);
BTJ22:=控盘>REF(控盘,1) AND 控盘<0;
BTJ3:=CROSS(财,神) AND 财<(-0.3);
BTJ32:=CROSS(财,神) AND 财<(-0.1);
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND 财>1.618;
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
有庄:=IF(BTJ81,1,0);
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
VAR11:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR22:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VAR33:=SMA(VAR22,2,1);
CJFSNN:=SMA(VAR33,2,1);
CJFSMM:=ABS(VAR11);
买:=STICKLINE(CROSS(CJFSNN,CJFSMM),3,20,2,0);
可买:IF(买,上轨,支撑位)COLORYELLOW,LINETHICK2;
必买:IF(BTJ81,上轨,支撑位)COLORYELLOW,LINETHICK2;
VAR3:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
VAR6:=FILTER(趋势>=90 AND VAR4,10);
卖1:=IF(VAR6,5,0);
卖2:=IF(STJ81,3,0),COLORLICYAN;
STJ82:=FILTER(STJ02 AND STJ32,13);
STJ83:=STJ81 AND STJ82;
清仓:=IF(STJ83,4,0),COLORRED;
DRAWICON(可买 ,上轨,23);
版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文