通达信仓位管理指标公式

秀股网财经 通达信公式 2019-08-29 18:38:36

满仓:1,POINTDOT,COLORRED;
粉色五成:0.5,POINTDOT,COLORLIRED;
灰色五成:0.5,POINTDOT,COLORGRAY;
清仓:0,COLORWHITE;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR2:=EMA(EMA(EMA(VAR1,4),4),4);
VAR3:=(VAR2-REF(VAR2,1))/REF(VAR2,1)*100;
VAR4:=MA(VAR3,2);
VAR5:=EMA(CLOSE,5)-EMA(CLOSE,55);
VAR6:=EMA(VAR5,10);
STICKLINE(VAR3>VAR4 AND VAR5<VAR6,0,0.5,3.7,0),COLORLIRED;
STICKLINE(VAR3>VAR4 AND VAR5>VAR6,0,1,3.7,0),COLORRED;
STICKLINE(VAR3<VAR4 AND VAR5>VAR6,0,0.5,3.7,0),COLORGRAY;
STICKLINE(VAR3<VAR4 AND VAR5<VAR6,0,0.05,3.7,0),COLORWHITE;
DRAWICON(VAR3>VAR4 AND VAR5<VAR6 AND REF((VAR3>VAR4 AND VAR5<VAR6)<1,1),0.5,23);
DRAWICON(VAR3>VAR4 AND VAR5>VAR6 AND REF((VAR3>VAR4 AND VAR5>VAR6)<1,1),0.9,9);
DRAWICON(VAR3<VAR4 AND VAR5>VAR6 AND REF((VAR3<VAR4 AND VAR5>VAR6)<1,1),0.65,2);
DRAWICON(VAR3<VAR4 AND VAR5<VAR6 AND REF((VAR3<VAR4 AND VAR5<VAR6)<1,1),0.2,15);

 

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文