通达信组合三趋势指标公式

秀股网财经 通达信公式 2019-08-21 00:49:44

使用说明:
组合三趋势副图指标的使用方法和源码:
1《组合三趋势》副图指标是利用短期、中期、长期等三条趋势线和五条彩带显示股价的目前走势趋势及操盘应选择的方法。
2 底部的3条彩带分别显示成交量(5日,10日)、MACD、KDJ指标的金叉或死叉状况,进一步明确指示股价的趋势。
3 顶部的2条彩带分别显示短期趋势线和中期趋势线的金叉、死叉及长期趋势线的走势情况,提示买入和卖出的时机。
4 当短期趋势线分别处于超买(80)或超卖(20)区域时,用小竖条图形予以提示。
5 长期趋势线上升或下跌分别代表走势的强弱,分别在上部的长期线彩带表示。
6 根据自己的操盘习惯,分别采取长期趋势线或短期趋势线与中期趋势线的走势情况(关注顶部的两条彩带)采用不同的操盘方法。

20,POINTDOT;
80,POINTDOT;
VOLUME:=VOL,VOLSTICK;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
STICKLINE(MAVOL1>=MAVOL2,0,-6,4,0),COLORFF00FF;
STICKLINE (MAVOL1<MAVOL2,0,-6,4,0),COLOR00FFFF;
成交量叉:MAVOL1>MAVOL2,POINTDOT;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;
STICKLINE (DIF>=DEA,-8,-14,4,0),COLORFF00FF;
STICKLINE (DIF<DEA,-8,-14,4,0),COLOR00FFFF;
MACD叉:DIF>DEA,POINTDOT;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE (K>=D,-16,-22,4,0),COLORFF00FF;
STICKLINE (K<D,-16,-22,4,0),COLOR00FFFF;
KDJ叉:K>D POINTDOT;
AA:-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))+100,COLORRED;
BB:EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100,COLOR00FFFF;
CC:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19)+100;
{秀股网-股票公式网站 www.xiugu5.com}
STICKLINE(CC>=REF(CC,1),CC+3,CC-3,1,1),COLORFF00FF;
STICKLINE(CC<REF(CC,1),CC+3,CC-3,1,1),COLOR00FFFF;
STICKLINE(AA>=BB,100,106,4,0),COLORRED;
STICKLINE(AA<BB,100,106,4,0),COLOR00FF00;
短中线叉:AA>BB,POINTDOT;
STICKLINE(CC>=REF(CC,1),108,114,4,0),COLORRED;
STICKLINE(CC<REF(CC,1),108,114,4,0),COLOR00FF00;
长线强弱:CC>=REF(CC,1),POINTDOT;
DRAWTEXT(CURRBARSCOUNT=4,-3,'VOL'),COLORFF0000;
DRAWTEXT(CURRBARSCOUNT=4,-11,'MACD'),COLORFF0000;
DRAWTEXT(CURRBARSCOUNT=4,-19,'KDJ'),COLORFF0000;
DRAWTEXT(CURRBARSCOUNT=4,103,'短中线'),COLORFF0000;
DRAWTEXT(CURRBARSCOUNT=4,111,'长期线'),COLORFF0000;
STICKLINE(AA>80 ,93,98,1,1),COLORFFFF00 ;
STICKLINE(AA<20 ,2,7,1,1),COLORFF0099;

 

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文