通达信出击趋势线指标公式

通达信公式 2019-08-16 22:37:49

VARAA:=AMOUNT/(100*VOL);
CYC13:=MA(VARAA,13);
CYC34:=MA(VARAA,34);
CYCMAX:=DMA(C,VOL/CAPITAL);
CYS13:=(C-CYC13)/CYC13*100;
CYS34:=(C-CYC34)/CYC34*100;
CYSMAX:=(C-CYCMAX)/CYCMAX*100;
IF(CYS13<=-7,7,0),COLORWHITE,STICK,LINETHICK3;
IF(CYS13<=-10,10,0),COLORFFFF33,STICK,LINETHICK3;
WEN:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
趋势线:=WEN;
{www.xiugu5.com 秀股网_通达信股票指标公式}
红柱:IF(COUNT(趋势线<REF(趋势线,1) AND 趋势线<10,2)=2,15,0),LINETHICK2,COLORRED;
VAR18:=(HIGH+LOW+CLOSE)/3;
VAR19:=(VAR18-MA(VAR18,14))/(0.015*AVEDEV(VAR18,14));
VAR1A:=(VAR18-MA(VAR18,70))/(0.015*AVEDEV(VAR18,70));
VAR1B:=IF(VAR19>=150 AND VAR19<200 AND VAR1A>=150 AND VAR1A<200,-10,0);
VAR1C:=IF(VAR19<=-150 AND VAR19>-200 AND VAR1A<=-150 AND VAR1A>-200,10,0);
VAR1D:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR1E:=100-ABS(VAR1D);
出击2:IF(BARSCOUNT(CLOSE)<13,10,IF(VAR1E<92 AND VAR1D<0,10,0)),COLORF00FF0,LINETHICK2;
出击1:IF(BARSCOUNT(CLOSE)<70,-10,IF(VAR1A<=-200 AND VAR19<=-150,15,VAR1C)-10),COLORRED,LINETHICK2,;
DRAWTEXT(ISLASTBAR,-10,' 高安全区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,0,' 安全区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,60,' 风险区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,80,' 高风险区'),COLORWHITE;

 

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文