通达信支撑预测主图指标公式

通达信公式 2019-08-12 18:53:55

买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,13)*21+C,49);
支撑预测:IF(买线<卖线,REFDATE(HHV(H,34),DATE)-(REFDATE(HHV(H,34),DATE)-REFDATE(LLV(L,34),DATE))*(1-0.236),DRAWNULL){REFDATE(LLV(L,34),DATE)+(REFDATE(HHV(H,34),DATE)-REFDATE(LLV(L,34),DATE))*(1-0.236))},COLORYELLOW,NODRAW;
STICKLINE(CURRBARSCOUNT=1,支撑预测,支撑预测,200,-1),COLOR00FFFF;
压力预测:IF(买线>卖线,REFDATE(LLV(L,34),DATE)+(REFDATE(HHV(H,34),DATE)-REFDATE(LLV(L,34),DATE))*(1-0.236),DRAWNULL),COLORRED,NODRAW;
STICKLINE(CURRBARSCOUNT=1,压力预测,压力预测,200,-1),COLORFF00FF;
DRAWTEXT(ISLASTBAR,支撑预测,STRCAT(' 【支撑关键位】 ',STRCAT(CON2STR(支撑预测,2),' 元'))),COLORFFFFFF,LINETHICK1;
DRAWTEXT(ISLASTBAR,压力预测,STRCAT(' 【压力关键位】 ',STRCAT(CON2STR(压力预测,2),' 元'))),COLORFFFFFF,LINETHICK1;

 

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文