把主图和副图公式改成通达信的

秀股网财经 公式技巧 2019-08-15 14:55:51

编写要求:

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20); DD:=DMA(CLOSE,CC); 上:=(1+7/100)*DD; 下:=(1-7/100)*DD; MA5:=ma(c,5); DRAWGBKLAST(MA5>=ref(MA5,1),STRIP(RGB(0,150,0),RGB(150,0,0),1)); DRAWGBKLAST(MA5<=ref(MA5,1),STRIP(RGB(150,0,0),RGB(0,150,0),1)); X:=BARSLAST(DISPSTATUS=1)+1; DRAWTEXTABS(0,0,'['+STKLABEL+']'+ STKNAME+':【可视:'+X+'天,】'),Color0077FF,LINETHICK7,LAYER3; 现价: if (DYNAINFO(4)=0,C,DYNAINFO(7)),color0077FF,POINTDOT; KC:=(2*C+H+L+O)/5; CB:=MEMA(KC,5); Xl:=slope(CB,3)>0; 价值线:CB; PARTLINE(CB,Xl-1,rgb(0,255,0),1,rgb(255,0,0) ),LINETHICK3,LAYER3; 反弹线:ma(CB,10) ,color9999FF,LINETHICK3; 顶线:上+ABS(cb-ma(cb,10))*0.9,COLORWHITE; 底线:下-ABS(cb-ma(cb,10)),COLORWHITE; Var1:=(HIGH+LOW+OPEN+CLOSE)/4; Var3:=2*EMA(LLV(Var1,7),10)-Var1; 黄金线:MA(3*Var1-2*SMA(Var1,2,1),12),coloryellow; 乾坤线:3*Var3-2*SMA(Var3,10,1),COLORGREEN; close, colorblue,linethick0; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color070084; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),color0000A3; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color0000B7; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color0000CD; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color0000E9; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color0754E9; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color076EF3; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color077BF3; STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color0726CA; STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color0726CA; STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorDE9100; STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorDE9100; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,9,0),color0090FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,8,0),color009FFF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,4,0),color00B5FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,2,0),color00E4FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),OPEN,LOW,0.7,0),color00FFFF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,HIGH,0.7,0),color00FFFF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),OPEN,LOW,0.7,0),colorFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,HIGH,0.7,0),colorFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,9,0),colorFF00FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,6,0),colorFF62FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,4,0),colorFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,2,0),colorFFA8FF; STICKLINE(l>ref(h,1),l,ref(h,1),50,1),COLORRED;

秀股网解答:

 CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

DD:=DMA(CLOSE,CC); 上:=(1+7/100)*DD; 下:=(1-7/100)*DD; MA5:=MA(C,5);   DRAWGBK(MA5>=REF(MA5,1),RGB(0,150,0),RGB(150,0,0),0,'',0);  DRAWGBK(MA5<=REF(MA5,1),RGB(150,0,0),RGB(0,150,0),0,'',0);    {X:=BARSLAST(DISPSTATUS=1)+1; DRAWTEXTABS(0,0,'['+STKLABEL+']'+ STKNAME+':【可视:'+X+'天,】'),COLOR0077FF,LINETHICK7,LAYER3;} 现价: IF(DYNAINFO(4)=0,C,DYNAINFO(7)),COLOR0077FF,POINTDOT; KC:=(2*C+H+L+O)/5; CB:MEMA(KC,5); XL:=SLOPE(CB,3)>0; 价值线:CB; {PARTLINE(CB,XL-1,RGB(0,255,0),1,RGB(255,0,0) ),LINETHICK3,LAYER3;} IF(XL,CB,DRAWNULL),LINETHICK3,COLORRED; IF(XL-1,CB,DRAWNULL),LINETHICK3,COLORGREEN; 反弹线:MA(CB,10) ,COLOR9999FF,LINETHICK3; 顶线:上+ABS(CB-MA(CB,10))*0.9,COLORWHITE; 底线:下-ABS(CB-MA(CB,10)),COLORWHITE; VAR1:=(HIGH+LOW+OPEN+CLOSE)/4; VAR3:=2*EMA(LLV(VAR1,7),10)-VAR1; 黄金线:MA(3*VAR1-2*SMA(VAR1,2,1),12),COLORYELLOW; 乾坤线:3*VAR3-2*SMA(VAR3,10,1),COLORGREEN;   CLOSE, COLORBLUE,LINETHICK0;   STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3,0),COLORFF5B00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2.6,0),COLORFF6C00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2.2,0),COLORFF7B00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.8,0),COLORFF9C00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.4,0),COLORFFBE00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1,0),COLORFFCC00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,0.6,0),COLORFFFF00; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),COLOR070084; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2.6,0),COLOR0000A3; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2.2,0),COLOR0000B7; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.8,0),COLOR0000CD; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.4,0),COLOR0000E9; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),COLOR0754E9; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,0.6,0),COLOR076EF3; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,0,0),COLOR077BF3; STICKLINE((CLOSE > OPEN),OPEN,LOW,0,0),COLOR0726CA; STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0,0),COLOR0726CA; STICKLINE((OPEN > CLOSE),CLOSE,LOW,0,0),COLORDE9100; STICKLINE((OPEN > CLOSE),OPEN,HIGH,0,0),COLORDE9100; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,3,0),COLOR0090FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,2.4,0),COLOR009FFF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,1.8,0),COLOR00B5FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,1.2,0),COLOR00E4FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),OPEN,LOW,0,0),COLOR00FFFF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,HIGH,0,0),COLOR00FFFF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),OPEN,LOW,0,0),COLORFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,HIGH,0,0),COLORFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,OPEN,3,0),COLORFF00FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,OPEN,2.4,0),COLORFF62FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,OPEN,1.8,0),COLORFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,OPEN,1.2,0),COLORFFA8FF; STICKLINE(L>REF(H,1),L,REF(H,1),50,1),COLORRED;   CJL:EMA(V,20); DKX:EMA(V,30)/3.5+EMA(V,5)/3.5+EMA(V,20)/3.5+EMA(V,135)/8,COLORRED; DRAWBAND(DKX,RGB(255,0,0),0,RGB(0,0,0));
版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文