出红色大叉选股

秀股网财经 公式技巧 2019-08-13 20:58:03

编写要求:

如题,公式如下,要求在出红叉的地方选股 SJV:=FINANCE(34);{每股净资产} 市净率:C/SJV,NODRAW,COLOR00FF00; 每股税后利润:=(FINANCE(1)/FINANCE(29)); 市盈率:C/FINANCE(33),NODRAW,COLORFFFF00; DIF:=EMA(CLOSE,10)-EMA(CLOSE,22); DE:=EMA(DIF,7.5); MACDA:=2*(DIF-DE),; HZL:=CROSS(MACDA,0); LZH:=CROSS(0,MACDA); BC:=BARSLAST(HZL OR LZH)+1; ZGHZ:=IF(MACDA>0,HHV(MACDA,BC),0); ZGLZ:=IF(MACDA<0,LLV(MACDA,BC),0); DRAWBAND(ZGHZ,RGB(105,77,77),0,RGB(77,77,77)); DRAWBAND(ZGLZ,RGB(80,0,0),0,RGB(66,88,66)); DIFF:EMA(CLOSE,10)-EMA(CLOSE,22),COLORFFFFFF; DEA:EMA(DIFF,7.5),COLOR00FFFF; MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK0; STICKLINE(MACD>0 AND MACD>REF(MACD,1),0,MACD,1.5,1),COLORRED; STICKLINE(MACD>0 AND MACDREF(MACD,1),0,MACD,1.5,0),COLORFFAAFF; ↑:TROUGHBARS(3,3,1),COLOR0000FF,NODRAW; ↓:PEAKBARS(3,3,1),COLOR00FF00,NODRAW; 低:IF(↑=0,DIFF,IF(↓<↑,TROUGH(3,3,1),REF(TROUGH(3,3,1),1))),COLOR00FFFF,NODRAW; 高:IF(↓=0,DIFF,IF(↑<↓,PEAK(3,3,1),REF(PEAK(3,3,1),1))),COLOR00FF00,NODRAW; STICKLINE(↑=0 AND DIFF<0 AND DIFF0 AND DIFF>DEA,DIFF,0,0,0),COLOR00FF00; DRAWTEXT(↑=0 AND DIFF<0 AND DIFF0 AND DIFF>DEA,DIFF,'高'),COLOR00FF00; 低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1; JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0)); 二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1; AA1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); 底背离:=(REF(L,AA1+1)>L OR REF(C,AA1+1)>C) AND (L,DIFF)>REF((L,DIFF),AA1+1) AND CROSS(DIFF,DEA); DRAWLINE(AA1=0,DEA,底背离,DEA,0),COLOR0000FF,LINETHICK1; AA2:=BARSLAST(REF(CROSS(DEA,DIFF),1)); 顶背离:=(REF(C,AA2+1)(H,DIFF) AND CROSS(DEA,DIFF); DRAWLINE(AA2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK1; DRAWICON(CROSS(DIFF,DEA) AND DIFF>0,DEA,36); DRAWICON(CROSS(DEA,DIFF) AND DIFF>0,DEA,37); DRAWICON(CROSS(DIFF,DEA) AND DIFF<0,DEA,1); DRAWICON(二次金叉,DEA*0.9,36) ; 解盘1:=CONST(IF(MACD>0,1,0)); 解盘2:=CONST(IF(MACD<0,1,0)); 解盘A:=IF(解盘1=1,'【精华8个字 买小卖小,缩头缩脚】 当股价一波比一波高时,反而红柱的堆, 一堆比一堆小,证明产生了顶背离现象,应该及时卖出', IF(解盘2=1,'【精华8个字 买小卖小,缩头缩脚】 当股价一波比一波低时, 反而绿柱的堆一堆比一堆小,证明产生了底背离,应该买进', DRAWNULL)); DRAWTEXT_FIX((解盘1=1 OR 解盘2=1),0.16,0,0,解盘A),COLORFFEE00;

秀股网解答:

 DIFF:=EMA(CLOSE,10)-EMA(CLOSE,22);

DEA:=EMA(DIFF,7.5); JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0)); 二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1; (CROSS(DIFF,DEA) AND DIFF>0) or 二次金叉;
版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文