把准备买入和黑马两个选股公式同时满足条件时做选股公式

秀股网财经 公式技巧 2019-08-13 20:57:50

编写要求:

准备买入 LY:=10; BL:=40; CJQS:=XMA(CLOSE,LY); JBQS:=XMA(CLOSE,BL); N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT); M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT); JB上轨:=IF(CURRBARSCOUNT>BL/2,JBQS*1.REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*1.1); JB下轨:=IF(CURRBARSCOUNT>BL/2,JBQS*0.9,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9); CJ上轨:=IF(CURRBRSCOUNT>LY/2,CJQS*1.05,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CUBARSCOUNT)*1.05); CJ下轨:=IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1-CUBARSCOUNT)*POW(M,LY/2+1-CURRBAROUNT)*0.95); XG:O<=CJ下轨; 黑马 DIFF0:=(EM)-EMA(DCSE,))*1; :=EMA(DFF0,); D0:=2*(DIFF00); 黑马:MACREF(MACD0,1)*2.5ACD0>15;

秀股网解答:

 LY:=10;

BL:=40; CJQS:=XMA(CLOSE,LY); JBQS:=XMA(CLOSE,BL); N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT); M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT); JB上轨:=IF(CURRBARSCOUNT>BL/2,JBQS*1.1,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*1.1); JB下轨:=IF(CURRBARSCOUNT>BL/2,JBQS*0.9,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9); CJ上轨:=IF(CURRBARSCOUNT>LY/2,CJQS*1.05,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*1.05); CJ下轨:=IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*0.95); XG:=O<=CJ下轨;     DIFF0:=(EMA(DCLOSE,12)-EMA(DCLOSE,26))*100; DEA0:=EMA(DIFF0,9); MACD0:=2*(DIFF0-DEA0); 黑马:=MACD0>REF(MACD0,1)*2.5 AND MACD0>15;   XG1:XG AND 黑马;
版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文