把第6条黄线变成其他颜色

秀股网财经 公式技巧 2019-08-13 20:57:35

编写要求:

比如COLORFFFF00 指标代码如下:n 最小30 最大10000 缺省1000 高1:=HHV(H,N); 低1:=LLV(L,N); H1:=高1-(高1-低1)*0.1428; H2:=高1-(高1-低1)*0.2857; H3:=高1-(高1-低1)*0.4285; H4:=高1-(高1-低1)*0.5714; H5:=高1-(高1-低1)*0.7142; H6:=高1-(高1-低1)*0.8571; 高:REFDATE(高1,DATE); 低:REFDATE(低1,DATE); 一:REFDATE(H1,DATE); 二:REFDATE(H2,DATE); 三:REFDATE(H3,DATE); 四:REFDATE(H4,DATE),COLORRED; 五:REFDATE(H5,DATE); 六:REFDATE(H6,DATE); {DRAWTEXT(CURRBARSCOUNT=1.00,一,'一(0.1428)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,二,'二(0.2857)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,三,'三(0.4285)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,四,'四(0.5714'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,五,'五(0.7142)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,六,'六(0.8571)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,高,'高'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,低,'低'),COLORYELLOW; DRAWKLINE(H,O,L,C);};

秀股网解答:

 高1:=HHV(H,N); 

低1:=LLV(L,N); H1:=高1-(高1-低1)*0.1428;  H2:=高1-(高1-低1)*0.2857;  H3:=高1-(高1-低1)*0.4285;  H4:=高1-(高1-低1)*0.5714;  H5:=高1-(高1-低1)*0.7142; H6:=高1-(高1-低1)*0.8571; 高:REFDATE(高1,DATE),COLORFFFFFF; 低:REFDATE(低1,DATE),COLOR00FFFF; 一:REFDATE(H1,DATE),COLORFF00FF; 二:REFDATE(H2,DATE),COLOR00FF00; 三:REFDATE(H3,DATE),COLOR888888; 四:REFDATE(H4,DATE),COLORRED; 五:REFDATE(H5,DATE),COLORFFFF00; 六:REFDATE(H6,DATE),COLORFF0000; {DRAWTEXT(CURRBARSCOUNT=1.00,一,'一(0.1428)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,二,'二(0.2857)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,三,'三(0.4285)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,四,'四(0.5714'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,五,'五(0.7142)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,六,'六(0.8571)'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,高,'高'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=1.00,低,'低'),COLORYELLOW; DRAWKLINE(H,O,L,C);};  
版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文