把黄色买点改为盘中预警

秀股网财经 公式技巧 2019-08-13 20:55:13

编写要求:

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VARD:=CLOSE=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1; STICKLINE(VAR19,L,L*0.98,3,0),COLORYELLOW; VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD; STICKLINE(VAR1A,H*1.01,H,3,0),COLOR00FF00{98FD}; XXMA:MA(C,5),COLORWHITE; DD5:=XXMA多空线); IF(A,多空线,DRAWNULL),COLORYELLOW,POINTDOT; A1:=(XXMA<多空线); IF(A1,多空线,DRAWNULL),COLORWHITE; V1:=CLOSE*VOL; V2:=EMA(V1,13)/EMA(VOL,13); CYS:=(EMA((CLOSE-V2)/V2,1)*100); AA:=CYS; MIDD:=MA(CYS,20); CC:=MIDD+0.85*STD(CYS,10); TM6:=AA>CC; IF(TM6,XXMA,DRAWNULL),COLORRED,LINETHICK2; 请问 老师可以把图中的黄色买点改为盘中预警啊 谢谢老师 辛苦啦

秀股网解答:

 var1:=c>ref(c,1) and c>ref(c,2);

var2:=ref(var1,1) and c<=ref(c,1) and c>=ref(c,2); var3:=ref(var2,1) and c>=ref(c,1) and c<=ref(c,2); var4:=ref(var3,1) and c<=ref(c,1) and c>=ref(c,2); var5:=ref(var4,1) and c>=ref(c,1) and c<=ref(c,2); var6:=ref(var5,1) and c<=ref(c,1) and c>=ref(c,2); var7:=ref(var6,1) and c>=ref(c,1) and c<=ref(c,2); var8:=ref(var7,1) and c<=ref(c,1) and c>=ref(c,2); var9:=ref(var8,1) and c>=ref(c,1) and c<=ref(c,2); vara:=ref(var9,1) and c<=ref(c,1) and c>=ref(c,2); varb:=ref(vara,1) and c>=ref(c,1) and c<=ref(c,2); varc:=ref(varb,1) and c<=ref(c,1) and c>=ref(c,2); vard:=c<ref(c,1) and c<ref(c,2); vare:=ref(vard,1) and c>=ref(c,1) and c<=ref(c,2); varf:=ref(vare,1) and c<=ref(c,1) and c>=ref(c,2); var10:=ref(varf,1) and c>=ref(c,1) and c<=ref(c,2); var11:=ref(var10,1) and c<=ref(c,1) and c>=ref(c,2); var12:=ref(var11,1) and c>=ref(c,1) and c<=ref(c,2); var13:=ref(var12,1) and c<=ref(c,1) and c>=ref(c,2); var14:=ref(var13,1) and c>=ref(c,1) and c<=ref(c,2); var15:=ref(var14,1) and c<=ref(c,1) and c>=ref(c,2); var16:=ref(var15,1) and c>=ref(c,1) and c<=ref(c,2); var17:=ref(var16,1) and c<=ref(c,1) and c>=ref(c,2); var18:=ref(var17,1) and c>=ref(c,1) and c<=ref(c,2); 黄:ref(vard or vare or varf or var10 or var11 or var12 or var13 or var14 or var15 or var16 or var17 or var18,1) and var1;
版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权本站发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文